10

Chapter

The Serial Section Manager
Stereo Investigator has been designed to facilitate serial section reconstruction of light and video
microscopy sections, EM photomicrographs, image stacks, and trans-illuminated negatives. The depth
separation between sections can range from a fraction of a micron to hundreds of microns. Sections can be
contiguous or non-contiguous, and can be oriented at different angles on specimen slides or data tablets.
The serial section reconstruction procedure allows you to specify the depth separation between
consecutive sections, and allows you to properly align the sections.
The Serial Section Manager allows data files traced in Stereo Investigator to be reconstructed for full
volumetric analysis and solid representation using Neurolucida Explorer. Using Stereo Investigator for
stereological analysis of tissue does not require any special alignment of tracings for accurate data
collection. However, in generating 3D solid objects, care must be taken to align sections to create a
smooth surface on the solid representation. Since the procedure for tracing from slides differs slightly from
that for tracing photomicrographs, camera lucida drawings, MRIs, etc., users should refer to the
instruction sections Serial Sections from Imported Image Files or Serial Sections from a Data Tablet if you
are not tracing from slides.
We designed this feature to facilitate serial section reconstruction of light and video microscopy sections,
EM photomicrographs, confocal stacks, and trans illuminated negatives. The depth separation between
sections can range from a fraction of a micron to hundreds of microns. Sections can be contiguous or noncontiguous, and can be oriented at different angles on specimen slides or data tablets.
The serial section reconstruction procedure allows you to specify the depth separation between
consecutive sections, and allows you to properly align the sections.

The Coordinate System
Stereo Investigator employs a right-handed Cartesian coordinate system. When you focus down through a
section the depth value increases in the negative direction. Thus, if sections are 10mm thick, and the top
of the section is at a depth of 0, the bottom of the section is at a depth of -10mm.

Fiducial Points
Fiducial points are points on your specimen that you mark to help you align subsequent sections. Fiducial
points, then, should be points that are present in all sections of the structure you are reconstructing. If the
tissue has a cut edge, a point along this line can be a fiducial point. Other examples of good fiducial points
include points along the central canal of the spinal cord, the central sulcus of the brain (in coronal
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sections), or the aorta in transverse embryo sections. Generally, any structure that runs longitudinally
through the entire structure you have sectioned lends itself to the placement of good fiducial points.
If there is not a structure that is present in all sections, as is often the case, it is recommended to mark
fiducial points on each section that are also found on the next section. Then each section is matched
with the tracing of the preceding tracing, not the first tracing.

The best placement of fiducial points is done by selecting the points at a low magnification, then going to
a higher magnification to adjust the placement of the points as accurately as possible.
Note that the alignment of sections is a bit of a subjective process. Fiducial points are just another tool to
help you do it as accurately as possible. If their placement is not precise, they are still of help.

Preparing Tissues for Serial Section Reconstruction
3D reconstruction through multiple sections is far easier if your tissue is sectioned and prepared in a
systematic fashion. Below are guidelines to make progress simple and fast. Note that if you have not
followed these guidelines, you can still do serial section reconstructions. One of the strengths of Stereo
Investigator is that you can flip sections mounted upside down, and use shrinkage corrections to
compensate for many irregularities.

Guidelines
• Have all sections aligned in the same orientation. This can be done by sectioning directly onto
slides or by making some kind of identifying mark in symmetrical tissues that are going to be
processed free floating. Try to have all sections mounted in the same Z orientation (right side up).
It is much easier to use Stereo Investigator to flip the occasional upside-down section than to
depend on that tool to orient all of your sections.
• Have sections mounted in order on slides. The bottom of one section is aligned with the top of the
next section to insure continuity of tracing.
• Mount every section when applicable. While this is not necessary for 3D reconstruction of large
solids, you cannot reconstruct neurons without every section.
• Keep track of any missing sections in your notebook. It can be very frustrating searching for the
‘next’ section during neuron reconstruction if it is not there.
• Don’t try to mount too many sections per slide and don’t try to mount them too close to the edges
of the slide (especially the left and right edges): you may not be able to trace all the way to the edge
of the slide without the condenser cap hitting the stage.
• Pick a good naming convention for your slides and sections. If you are not mounting every section,
include the logical and actual section number in the section name. For instance, if you are
mounting every 5th section cut, the postfix for the first mounted section could be 1-1, while for
the second mounted section it could be 2-6, indicating that it is the second actual mounted
section, but the 6th section of the exhaustive (logical) series. It can also be useful to encode such
information as the experiment, group, animal, and slide # in each section name, although this
information can also be stored in the file description for the entire file.
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•

Select Objects Not in a Section: You must first click Select by Section to use this command.
Sometimes you will have objects that aren't in any section. Use this command to select them for
editing.

•

Display Current Section Only: Displays just the current section in the list.

•

Show Suppressed as Gray: Displays suppressed objects as gray.

•

Display Flanking Sections: Displays the sections immediately above and below the current
section. For example, if section 9 is active, this command shows section 8 and section 10 as well.

Setting Up The Serial Section Manager And Tracing
Before sing the Serial Section Manager, you need to set its options. The instructions here will help you .

Setting Up Before Tracing
These instructions are for the set-up of a serial section reconstruction using the microscope and specimen
slides.
Do not start tracing the first section until you have gone through the following set-up procedures.

If you are reconstructing serial sections from imported images (digital images of specimens, MRI images,
or confocal stacks) see the appropriate section for specific set-up instructions.
1.

Click Acquisition>Live Image to display a live image. Be sure that the lens selected in the Lens
Selection Menu is the same as the lens selected on the microscope turret. Move the stage to select
an appropriate reference point. The reference point is only applicable to your first section, as it can
be moved during subsequent alignment functions. However, if you select a structure that is present
in most of your sections for your initial reference point, it can be helpful in placing the specimen
in the correct location when replacing a slide on the microscope.

After selecting a reference point, you may want to switch back to a relatively low power lens so
that as much of the region of interest as possible is in your field-of-view.
2.

Focus on the top of the current section.

3.

Click Tools>Serial Section Manager. Stereo Investigator displays the Serial Sections dialog box.
If this is the first time you are using the Serial Section Manager, no sections are displayed. You
must set up the Serial Section Manager.

4.

Click New Section. Stereo Investigator displays the Serial Section Setup dialog box.
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Note on Terms: In the following discussion, Section A refers to the section currently being traced or
which has just been traced; Section B is the next section to be mapped. Our discussion assumes that
sections are mapped in ascending serial order. It is not necessary to proceed in this way but it is usually
easier and more convenient.
To Trace Serial Sections:
1.

Select a contour type from the Contour toolbar, and trace Section A as completely as desired,
adjusting the focus as necessary. Use a different contour type for each different anatomical region
you plan to trace. If there are separate left and right components to an anatomical structure, such
as ventricles, it is often convenient to define separate contour types for each, for instance Left
Ventricle and Right Ventricle. It is often useful to trace the section outline, even if it is not needed
in your final study. If this is done the Macro View window can be used to see where you are at all
times and to move anywhere in the section quickly and easily using Go To.

Unless you are using a data tablet, you may change lenses at any time. Remember to always
change the lens in the Lens Selection List when you change the physical lens.
2.

It is a good idea to save your tracing frequently. Click File>Save As and save your file as either a
.dat or .asc file.

3.

Use Joy Free to move the slide to the next section. It is usually useful to switch back to a low
power objective for the move and align steps.

4.

Align Section B with the tracing of Section A as precisely as possible. You can find instructions in
the section that follows, "Aligning Serial Sections" below.

5.

Once the sections are well aligned, focus on the top of Section B, and click Tools>Serial Section
Manager and click the New button. At this point it is usually easier to hide the previous tracings,
i.e., make sure Display Current Section Only is pressed.

Remember, you do not need to open a new file for new sections. While it is possible to create a 3D
reconstruction from information saved in different files, Stereo Investigator is designed to store all
information for a reconstruction in a single file, and this is the easiest way for you to complete a
reconstruction.
6.

Trace Section B, then repeat steps 1-5 until you reach the last section of your specimen.

Aligning Serial Sections
The following instructions outline the procedure for aligning a new tissue section with the tracing
described in Tracing Serial Sections on page 75. This procedure is used in tracing serial sections. Section
A refers to the section that has just been traced, while Section B refers to the new section about to be
traced.
1.

Click Move>Joy Free. Move the stage with the joystick until Section B is aligned relatively well
with the tracing of Section A. Focus at the top of the section and exit Joy Free.

2.

You now need to further align the tracing of Section A with the specimen that is Section B. There
are a few ways to do this, depending on the degree and type of misalignment, as described here:
•

Tools>Match provides a best fit between the tracing and new specimen based on the
location of 2 to 99 pairs of corresponding points. This is the easiest method to obtain
a quick, good fit between the image and the tracing. Match rotates and moves the
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overlay, without skewing or altering it, to get the best match with your image. To
carry out a match, specify the number of pairs you are going to use for matching the
tracing with the section. For each pair, first pick a point on the overlay, and then pick
the corresponding point on the image. Repeat this for subsequent pairs. If this
requires moving the stage, use Move>Joy Track, the Go To function of the Macro
View window, the arrow buttons on the toolbar, or Go To to move to the next pair
of points. Match moves all sections whether displayed as visible or hidden.
•

Move>Align Tracing moves the tracing in the X, Y and/or Z-axis, but does not
rotate the tracing. When you select this option, instructions appear in the status bar
prompting you to first pick a point on the overlay (tracing), then to choose the point
on the specimen (Section B) where you want this point to appear. Refocus if necessary
before clicking on the second point. Align Tracing moves all sections whether
displayed as visible or hidden.

•

Tools>Rotate Tracing allows for simple rotation around the reference point. This
tool only rotates visible sections, so be sure that all sections are visible
(Options>Display Preferences>View tab, deselect Show Current Section Only) if
you are going to use this to align a new section. Rotate Tracing has the advantage
that you can see the tracing move while you are making the adjustment. Rotate
Tracing moves only sections displayed as visible.

Be sure that Display Current Section Only is not selected if you are using the Rotate Tracing option (that
is, be sure all sections are visible). If only one section is visible, that section is rotated out of alignment
with the previously traced stack of sections.
A note on the reference point: You may notice that after aligning the second section that the
reference point is not in its original location with regard to the tissue. This is normal, and is due to the
fact that align and match functions move the entire tracing not including the reference point. The
reference point is only an accurate locator of a point on your tissue in the first section of a stack. When
returning to subsequent sections after closing the file, you need to manually align the tissue with the
stack of tracings.

Serial Sections And Imported Images
Imported image files can be in several formats, including a series of images acquired from several slide
section. For confocal images, you don't need to use the Serial Section Manager—we treat the stack as a
single section. Moving between images is treated as changing focal planes.
For tracing from a series of imported image files, follow the same steps as tracing from slide material.
When working from acquired images, you need to know before beginning: the distance between sections,
OR the thickness of sections and periodicity of the sections from which the images were acquired. In
addition, you need to calibrate a lens to the scale of the acquired images if they were not acquired from the
system you are currently using. See Calibration for Imported Images for more information about
calibrating a lens for imported images.
1.

Place a reference point.

2.

Open the Serial Section Manager and define the first section.

3.

Open the first image.
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4.

Trace the first section as you would from a live slide image.

5.

Save the file.

6.

Open the image of the next section. The location of the new section is not important, as long as
the previous tracing is aligned with the image of the new section according to instructions found in
Aligning Serial Sections. The only difference in the procedure is that Move Image is used instead
of Joy Free.

7.

Align the previous tracing with the image of the next section.

8.

Define a new section.

9.

Trace the next section.

The serial section reconstructions have slightly less detail, as focusing through the tissue sections is not
possible, and tracings tend to have a "stair step" appearance as you move from section to section.
However, the steps to follow for moving from section to section are identical to those for working with
slide material.

Using A Data Tablet With Serial Sections
You can trace from a photomicrograph by using a data tablet. If you have images that have been scanned
or digitally photographed, there is no need to use a data tablet, as these images can now be imported
directly into Stereo Investigator for tracing. See Serial Sections and Imported Images on page 77 for
instructions on working with digital images.
How To Trace Serial Sections With A Data Tablet
1.

Make sure you have calibrated a tablet lens based on the scale of the photomicrograph you are
tracing, and select that lens in the lens selection list. See Calibrating a Lens for Objects Placed on a
Data Tablet.

2.

Set up the Serial Section Manager according to the instructions in Serial Section Set Up. Enter
the distance between photomicrographs into the Enter the Section Thickness field of the Serial
Section Setup dialog box.

3.

Place the photomicrograph under the plastic cover sheet of the tab-let so that it cannot move while
being traced.

4.

Move the cross hair of the data tablet mouse (four button puck) until the cross hair lies on the
desired reference point and click the yellow mouse button. The reference point is used primarily
for locating your starting point in the first section. It should be a point that you can easily find
again on the first image.

5.

Follow the general directions for Tracing from Serial Sections.

6.

Continue tracing, treating each new photomicrograph as a new section until you have reached the
end of the tissue of interest.

Working With Serial Sections—Upside Down Mountings
Most of the time your work with Serial Sections will be straightforward. Occasionally, you may run into a
section mounted upside down. You can correct for an upside down section before starting to trace the
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section or you can correct an upside down section that has already been traced. Here's how to deal with
these sections.

Tracing Upside-down Mounted Sections
If you discover the upside down section before you start tracing it, use this procedure. You are most likely
to discover the upside down section before tracing has begun if your tissue is asymmetrical. In this case,
you are unable to align the tracings of previous sections with the current section, and need to flip the
tracings of the previous sections in order to align them with the new tissue section.
Start the following procedure before designating a new section in the Serial Section Manager.
An analogy to a loaf of bread can be used to describe this procedure: Imagine that you are putting a
loaf of bread back together one slice at a time. If you come across a slice that is upside down, one way
to put it on in the correct orientation is to take the entire loaf and bring it around to the other side of
that slice. Then you can put the slice on the loaf in the correct orientation without flipping the slice
itself. This is how we deal with an upside down section, by flipping all the other sections to the "other
side" of the inverted section by inverting the Z values. Then, once the upside down slice has been
added, the whole loaf, including the new slice, is flipped back around to continue adding slices
(sections).
1.

Deselect Options>Display Preferences >View tab>Show Current Section Only so that all
sections are visible.

2.

Click Tools>Shrinkage Correction and change the value of the Z field to -1.0. Also change the
value of either the X or Y field to -1.0, depending on whether you would like to flip the section
vertically or horizontally. Entering -1.0 in the X field flips the tracing left to right around the
reference point. Entering a -1.0 in the Y field flips the tracing top to bottom around the reference
point. If the reference point was not placed in the center of the section, the tracing may be flipped
so that it is no longer in the field-of-view. Use Move>Go To or the Go To command in the
Macro View window to move the tracing back into the field-of-view, and then use Joy Free or
Align to carefully re-align the section.

3.

Click Options>Display Preferences >View tab>Show Current Section Only to display only the
last section traced. You can now align this section with the upside down tissue section. Align the
tissue section with the tracing using techniques described in Aligning Serial Sections.

4.

Define the new section using Tools>Serial Section Manager. Type in the nominal depth value
for the bottom of this section in the Top of Section Depth field. To have the Z information
within the section recorded correctly, it is also necessary to invert the sign of the Z step size. Go to
Options>Stage Setup>XYZ Stage Setup and change the sign of the Z step size. Trace the upside
down section normally.

5.

When the section has been completely traced, flip all sections including the latest one right side up
again. Make all sections visible by deselecting Show Current Section Only, then click
Tools>Shrinkage Correction and change Z to -1.0, and either X or Y (the same one that you
changed before) to -1.0.

Don't forget to change the Z step size back to its original value.

Flipping Traced Data
This method can be applied to one or more individual sections in a data file after tracing is completed.
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1.

Click Options>Display Preferences>View tab and select Show Current Section Only and
Show Suppressed as Gray.

2.

Use Tools>Serial Section Manager to highlight the section to be flipped. Click on the section to
be flipped in the Section Z field to make that the active section.

3.

Click Tools>Shrinkage Correction. In the Shrinkage Correction dialog box enter -1.0 in the Z
field, and -1.0 in either the X or Y field depending on whether you would like to flip the section
vertically or horizontally. Entering -1.0 in the X field flips the tracing left to right around the
reference point. Entering a -1.0 in the Y field flips the tracing top to bottom around the reference
point. If the reference point was not placed in the center of the section, the tracing may be flipped
so that it is no longer in the field-of-view. Use Move>Go To or the Go To command in the
Macro View window to move the tracing back into the field-of-view, and then use Joy Free or
Align to carefully re-align the section..

4.

If the depth values of the flipped data need correcting to match them up with the original section,
click Edit>Select All Objects, and then right click and select Modify Z Position from the menu.
In the Modify Z Position dialog box, click on Shift Z Values, then type in the amount of
translation you want to apply to the section in order to correct its position in the serial stack.
Do not use Set Z Values, as this flattens all points in the section to a single Z Value.

5.

Use the Orthogonal View window to view the relative positions of a series of sections in a serial
stack.

6.

If you need to rotate or translate this section in X and Y to line it up with the other sections, use
Match Section. Select both Display Current Section and Show Suppressed as Gray, then click
Tools>Match Section. Choose a number of points to align. For each pair, click first on a point on
the current (color) section, then click on the location of the gray section where that point should
be. After the last pair of points has been placed, the tracing in the active section is re-aligned.

Tools>Match Section can also be used in conjunction with Tools>Where Is to see the entire tracing
while doing the match.
7.

Save the repaired serial section reconstruction in a newly named file, or if you are confident about
the transformation, save it under the original file name.
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